После избавления от Vendor постоянно выдает ошибки

В этой теме 4 ответа, 2 участника, последнее обновление  jesofa 09.01.2017 в 13:31.

Просмотр 5 сообщений - с 1 по 5 (из 5 всего)
  • Автор
    Сообщения
  • #97736

    jesofa
    Участник
    • Сообщений: 8

    Купила шаблон, сам шаблон оказался не рабочим. Пришлось Ставить демку, еле избавилась от Vendor. Все описанные в инете методы не помогли. Теперь постоянно выдает , что его невозможно найти :
    You are using single vendor mode, but it seems more than one user is set as vendor
    а так же появилась ошибка:
    Too few arguments in /home/bh61274/public_html/administrator/components/com_virtuemart/helpers/vmtext.php on line 139
    Подскажите что делать.
    Спасибо.

    #97737
    Messir
    Messir
    Участник
    • Сообщений: 663

    По вендору могу сказать только одно — зайдите через пхпмайдмин в таблицу #__virtuemart_vmusers и для нужного пользователя в полях:
    virtuemart_vendor_id
    user_is_vendor
    поставить значение «1«

    #97765

    jesofa
    Участник
    • Сообщений: 8

    у меня там 2 пользователя . для одного ( последнего по дате добавления ) стоят все единицы.
    для второго ( более раннего ) virtuemart_user_id значение 681, а в полях virtuemart_vendor_id и user_is_vendor стоят единицы.
    число 681 на 1 не меняется, ошибку выдает.
    может его вообще удалить?

    #97767
    Messir
    Messir
    Участник
    • Сообщений: 663

    Определитесь (по логину), какой из пользователей Вам нужен, того и оставьте. В указанных полях должны стоять единицы (остальные поля не нужны). Если нужны оба пользователя, то у ненужного в указанных полях (только в них!) смените значение с «1» на «0». Юзер_АйДи трогать не нужно.

    #97772

    jesofa
    Участник
    • Сообщений: 8

    спасибо, помогло.

Просмотр 5 сообщений - с 1 по 5 (из 5 всего)

Для ответа в этой теме необходимо авторизоваться.