Nicewatermark

В этой теме 7 ответов, 4 участника, последнее обновление admin admin 15.09.2017 в 11:08.

Просмотр 8 сообщений - с 1 по 8 (из 8 всего)
  • Автор
    Сообщения
  • #83445

    Alex21021
    Участник
    • Сообщений: 7

    Коллеги, помогите с настройками!
    Не могу разобраться!
    Загрузил с сайта плагин: http://spinch.net.ua/plagini/plagin-nice-watermark
    Встал, все Ок!
    Создал папку в каталоге, дальше не пойму…

    #92154
    Messir
    Messir
    Участник
    • Сообщений: 788

    Мой Вам совет — не связывайтесь Вы с этими плагинами… Нагрузка на сайт увеличивается в разы. Намного проще пакетно накладывать водяной знак ДО загрузки на сайт. Тем более что программ для этого великое множество)))

    #104830
    DarthOlolo
    DarthOlolo
    Участник
    • Сообщений: 5

    Понимаю, что тема стара и топикстартеру советовали не связываться с плагином, но всё таки я к нему тоже пришел и как по мне это наименее болезненный способ наложения ватермарки. Однако столкнулся с проблемой вывода ватермарки на фотографиях товара внутри карточки товара.
    Так как плагин привязывается к классу изображения, на фотографиях в категориях выводится ватермарк спокойно, там стоит изначально класс. Но вот с фотографией в карточке товара проблема — по умолчанию класса нет и никак не пойму как добавить.
    Методом тыка и поиска значения rel ссылки в которую обёрнуто фото товара, набрёл на view\productdetails\tmpl\default_images.php и default_images_additional.php но какие манипуляции не пробовал проводить класс присваивается только к ссылки. Так понимаю, что всё таки класс к таким фотографиям присваивается в совершенно другом месте, но не пойму где, подскажите пожалуйста, кто знает где это можно сделать?

    #104837
    admin
    admin
    Хранитель
    • Сообщений: 7884

    Попробуйте в default_images.php в
    $image->displayMediaThumb

    первом параметре передать класс
    $image->displayMediaThumb('class="test"',

    #104841
    DarthOlolo
    DarthOlolo
    Участник
    • Сообщений: 5

    Не выводится 🙁

    #104848
    admin
    admin
    Хранитель
    • Сообщений: 7884

    Должно работать, еще раз протестировал.
    Пришлите исправленный кусок с
    $image->displayMediaThumb

    #104856
    DarthOlolo
    DarthOlolo
    Участник
    • Сообщений: 5

    Как не странно, но сегодня попробовал вставить по другому и заработало…
    echo $image->displayMediaFull('class="test1"',"",true,"rel='vm-additional-images'"); эта запись сработала, а до этого пробовал без вторых двойных кавычек echo $image->displayMediaFull('class="test1"',true,"rel='vm-additional-images'");
    Однако с добавлением класса убирается ссылка для увеличения, в которую была обёрнута фотография товара.

    #104859
    admin
    admin
    Хранитель
    • Сообщений: 7884

    Нужно смотреть на сайт.
    Пришлите доступ к админке, доступ к сайту по ftp и ссылку на вопрос на admin@virtuemart.su, на выходных постараюсь посмотреть.

Просмотр 8 сообщений - с 1 по 8 (из 8 всего)

Для ответа в этой теме необходимо авторизоваться.